アーカイブ

依存gemの展開に失敗する件。 このエントリーを含むはてなブックマーク はてなブックマーク - 依存gemの展開に失敗する件。

2008 年 10 月 4 日 Comments off
% rails -v
Rails 2.1.1
% rake gems:unpack:dependencies
(in /home/yoshuki/projects/oibbs)
ERROR:  While executing gem ... (ArgumentError)
Illformed requirement ["\"= 2.0.2\""]

こんなこと言われてしまったら
rails-2.1.1/lib/rails/gem_dependency.rb

116         cmd << "--version" << %("#{@requirement.to_s}") if @requirement
123         cmd << "--version" << %("#{@requirement.to_s}") if @requirement

をそれぞれ

            cmd << "--version" << @requirement.to_s if @requirement

として回避する。

#1003 rake gems:unpack version handling broken – Ruby on Rails – rails

rake gems:unpack version handling broken

すでにチケットは切られている。

カテゴリー: Rails タグ: