アーカイブ

MongrelとApache2.2でRails。 このエントリーを含むはてなブックマーク はてなブックマーク - MongrelとApache2.2でRails。

2006 年 8 月 25 日 Comments off

10分で作るRailsアプリ for Windows」の増井さんに直に話を聞く機会があって、名前だけ知ってたMongrelがこれからいい感じジャマイカということを聞いたので、とりあえず環境を作ってみた。

Mongrel: Home

What is Mongrel?

Mongrel is a fast HTTP library and server for Ruby that is intended for hosting Ruby web applications of any kind using plain HTTP rather than FastCGI or SCGI.

で、具体的に参考にしたのはココ↓
Scaling Rails with Apache 2.2, mod_proxy_balancer and Mongrel
Lighttpdがボコボコとクラッシュするようになって、Basecampが動いてるApache1.3とFastCGIが良さげなので乗り換えようとしたんだけど、Apache1.3はロードバランスできないし、FastCGIとの組み合わせのドキュメントが少なすぎる。そしてApache2.0とmod_fastcgiは問題がある。っていうか、いっぱいある貧弱なマシンでFastCGIを動かそうとしてるから負荷分散が必要なんだよなー・・・お、Mongrelって良さげじゃね?ってことらしい。(超訳)

要はApache2.2をロードバランサにしちゃえってこと。mod_proxy_balancerで。
では、始めます。

続きを読む…

カテゴリー: Rails タグ: