ホーム > Java > 今後のTomcat

今後のTomcat このエントリーを含むはてなブックマーク はてなブックマーク - 今後のTomcat

2005 年 10 月 5 日

アプリケーション・サーバー「Tomcat 4.x」にセキュリティ・ホール:IT Pro

JP Vendor Status Notes(JVN)は9月30日,Javaアプリケーション(Java ServletやJSP)の実行環境であるオープンソースのアプリケーション・サーバー「Apache Tomcat 4.x」にセキュリティ・ホールが見つかったことを明らかにした。

だそうです。で、そのあと。

対策はTomcat 5.xにアップグレードすること。

いま開発のフォーカスがあるのは5.5.xで、5.5.xはJ2SE5.0を要求されるから、J2SE1.4.2の環境はJDKをあげないとダメじゃん。
じゃなくて、あらためて確認したら、

Apache Tomcat 5.5 is the current focus of development.

とはあるものの、5.0.xはもう終わりとはどこにもかいてない。5.0.30もβである
ということで、とんだ勘違いをしていたことが判明。どなたか、すでに騙していたらごめんなさい。

まとめ:4.xを使ってるところは5.0.xに入れ替えよう。(でも4.x→5.xでかなり変わってるから、いろいろあるかも。)


カテゴリー: Java タグ:
コメントは受け付けていません。